2.3.0 update:
! Mod using the old versions of this library won't work!
- reworked
BlockList
classes. They now are divided into parameters - added
BlockListManager
to manage a list pf blocksList - added
OrderedBlockList
, allowing you to order the blockPos of the BlockList. This replaces the previousList<Pair<BonckPos, BlockState>>
, this allows us to save some memory by not keeping duplicatedBlockStates
- performance improvements for spiral and torus
- changed a lot of packages, moved a lot of classes
- changed names of some classes (the names are still close. For example:
Shape
->AbstractBlockShape
- added some javadoc
- solved some minor bugs
- added some equation maths
- added
BlockSorter
class, allowing you to sort your BlockPos List. - changed
StructurePlaceAnimator
to includeBlockSorter
- added some
animationTime
- removed dev test classes
2.2.1 changelog
- fixed shape rotations (the rotations wasn't rotationg around the good axis)
- fixed a crash that could happend when adding BlockPos to a BlockList
- added some methods to BlockList
- added the possibility to get the BlockList list in the shape generation
- moved the test package so that there is not any devclass in the build
2.2.0 changelog
-new animator class that will create animations when placing features/structures
-Shape class now implements animator and can use the animations by using PlaceMoment.ANIMATED_OTHER
-changed the StructureUtil class to only implements useful data transformation methods.
-created NbtPlacer class that will load a nbt file in the world
-added some javadoc
-added some useful methods
Warning! Mods that used old version of this mod might not work.
Cleanup code update and update to 1.21.3
This version bring a lot of qol changes.
- reduced the nulber of warnings ~200 warnings -> ~15 warnings.
- more consise way of naming objects
- spelling mistakes fixed
- javadoc cleanup and addition
- performance improvements when using only one
BlockLayer
(2x to 3x faster) force
andblocksToForce
parameters moved toBlockLayer
classShape
class was divided into multiple classes for better maintainibility and readibility- some methods addition(some getter and setters for example)
- removed deprecated methods
Warning! Mods that used old version of this mod might not work.
Cleanup code update
This version bring a lot of qol changes.
- reduced the nulber of warnings ~200 warnings -> ~15 warnings.
- more consise way of naming objects
- spelling mistakes fixed
- javadoc cleanup and addition
- performance improvements when using only one
BlockLayer
(2x to 3x faster) force
andblocksToForce
parameters moved toBlockLayer
classShape
class was divided into multiple classes for better maintainibility and readibility- some methods addition(some getter and setters for example)
- removed deprecated methods